Добро пожаловать, Гость
Логин: Пароль: Запомнить меня

ТЕМА: Настройка multiwan на openwrt

Настройка multiwan на openwrt 26 сен 2012 13:29 #1

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13

При настройке multiwan на openwrt пользовался вот этой инструкцией. Так я объединит два интернет канала от разных провайдеров в один.

 

Подробнее...
Администратор запретил публиковать записи гостям.

Настройка multiwan на openwrt 20 янв 2013 11:44 #2

  • netwalker
  • netwalker аватар
  • Offline
  • Новый участник
  • Сообщений: 14
  • Репутация: 0
Здравствуйте :)
Вчера озадачился настройкой backup канала.
Хотелось бы чтобы USB модем, подключенный в USB хаб автоматом поднимал соединение при падении PPPoE на проводном канале (такое не часто, но бывает).
Попробовал данное реализовать средствами multiwan, но возможно, я что то не учел, потому что по одиночке соединения работают нормально, а вот автоматического "перехода" нет.
Не могли бы Вы подсказать, как это сделать.
Спасибо.
Администратор запретил публиковать записи гостям.

Настройка multiwan на openwrt 20 янв 2013 11:46 #3

  • netwalker
  • netwalker аватар
  • Offline
  • Новый участник
  • Сообщений: 14
  • Репутация: 0
Да, забыл показать конфиги, итак:
/etc/config/multiwan:
config 'interface' 'wan'
option 'weight' '10'
option 'health_interval' '10'
option 'icmp_hosts' 'dns'
option 'timeout' '3'
option 'health_fail_retries' '3'
option 'health_recovery_retries' '5'
option 'failover_to' 'wan3g'
option 'dns' 'auto'

config 'interface' 'wan2'
option 'weight' '10'
option 'health_interval' '10'
option 'icmp_hosts' 'dns'
option 'timeout' '3'
option 'health_fail_retries' '3'
option 'health_recovery_retries' '5'
option 'failover_to' 'wan2'
option 'dns' 'auto'
Администратор запретил публиковать записи гостям.

Настройка multiwan на openwrt 20 янв 2013 11:53 #4

  • netwalker
  • netwalker аватар
  • Offline
  • Новый участник
  • Сообщений: 14
  • Репутация: 0
/etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'

config interface 'wan'
option ifname 'eth1'
option _orig_ifname 'eth1'
option _orig_bridge 'false'
option proto 'static'
option ipaddr '172.22.114.241'
option netmask '255.255.0.0'
option gateway '172.22.100.1'
option accept_ra '1'
option defaultroute '1'
option dns '172.22.100.99 172.22.100.100'
Администратор запретил публиковать записи гостям.

Настройка multiwan на openwrt 20 янв 2013 11:54 #5

  • netwalker
  • netwalker аватар
  • Offline
  • Новый участник
  • Сообщений: 14
  • Репутация: 0
/etc/config/network (продолжение)
config interface 'wan2'
option _orig_ifname 'ppp0'
option _orig_bridge 'false'
option proto 'pppoe'
option username 'xxx'
option password 'xxx'
option ifname 'eth1'
option peerdns '0'
option dns '78.31.240.6 78.31.240.18'

config switch
option name 'rtl8366s'
option reset '1'
option enable_vlan '1'
option blinkrate '2'
option max_length '3'

config switch_vlan
option device 'rtl8366s'
option vlan '1'
option ports '0 1 2 3 5t'

config switch_port
option device 'rtl8366s'
option port '1'
option led '6'
Администратор запретил публиковать записи гостям.

Настройка multiwan на openwrt 20 янв 2013 11:56 #6

  • netwalker
  • netwalker аватар
  • Offline
  • Новый участник
  • Сообщений: 14
  • Репутация: 0
/etc/config/network (окончание)
config switch_port
option device 'rtl8366s'
option port '2'
option led '9'

config switch_port
option device 'rtl8366s'
option port '5'
option led '2'

config route
option interface 'wan'
option target '192.168.0.0'
option netmask '255.255.0.0'
option gateway '172.22.100.1'

config route
option interface 'wan'
option target '10.0.0.0'
option netmask '255.0.0.0'
option gateway '172.22.100.1'

config route
option interface 'wan'
option target '172.16.0.0'
option netmask '255.240.0.0'
option gateway '172.22.100.1'

config interface 'wan3g'
option proto '3g'
option device '/dev/ttyUSB0'
option service 'umts'
option apn 'internet'
option maxwait '60'
option metric '10'
Администратор запретил публиковать записи гостям.

Настройка multiwan на openwrt 20 янв 2013 11:58 #7

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
Быстро не подскажу, перепрошил роутер, надо заново настраивать, что бы сравнить конфиги((
Администратор запретил публиковать записи гостям.

Настройка multiwan на openwrt 20 янв 2013 15:36 #8

  • netwalker
  • netwalker аватар
  • Offline
  • Новый участник
  • Сообщений: 14
  • Репутация: 0
Быстро не подскажу, перепрошил роутер, надо заново настраивать, что бы сравнить конфиги((
Да хоть не быстро, но если подскажете, буду премного благодарен.
Спасибо.
Администратор запретил публиковать записи гостям.

Настройка multiwan на openwrt 01 мая 2013 17:54 #9

  • Кирилл
  • Кирилл аватар
Таким образом я смогу подключиться (мой роутер WDR-4300, на втором офисе Asus RT-N15) ко второму нашему офису с другим провайдером, принтерами и т.п. по wifi? Диапазон внутренних адресов там тоже другой: у меня 192.168.1.1-100 там 192.168.0.3
Администратор запретил публиковать записи гостям.

Настройка multiwan на openwrt 01 мая 2013 18:07 #10

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
Таким образом я смогу подключиться (мой роутер WDR-4300, на втором офисе Asus RT-N15) ко второму нашему офису с другим провайдером, принтерами и т.п. по wifi? Диапазон внутренних адресов там тоже другой: у меня 192.168.1.1-100 там 192.168.0.3

Я по этой инструкции настраивал роутер, что бы получать интерент от двух провайдеров. В вашем случае я не могу подсказать, не пробовал.
Администратор запретил публиковать записи гостям.

Настройка multiwan на openwrt 25 авг 2013 19:53 #11

  • dennz
  • dennz аватар
Таким образом я смогу подключиться (мой роутер WDR-4300, на втором офисе Asus RT-N15) ко второму нашему офису с другим провайдером, принтерами и т.п. по wifi? Диапазон внутренних адресов там тоже другой: у меня 192.168.1.1-100 там 192.168.0.3

Офисы соединены по вайфаю что ли?
в первом помещении один пров, во втором другой, роутер по вайфаю в соседнее помещение с другим провом цепляется по вайфаю, для бекапа?
или что вы имеете в виду?

Офисы по-нормальному, через инет объединяются в одну сеть по VPN, проще всего поднять на роутерах OpenWRT+OpenVPN точка-точка.
Хороший ман можно найти на wiki DD-WRT там пошагово. Будут мелкие изменения для OpenWRT, пути чтоль подправлять в скриптах пришлось...
Администратор запретил публиковать записи гостям.

Настройка multiwan на openwrt 25 авг 2013 22:32 #12

  • netwalker
  • netwalker аватар
  • Offline
  • Новый участник
  • Сообщений: 14
  • Репутация: 0
Простите, что вмешиваюсь.
Господа, если не трудно, напишите пожалуйста что то типа гайда по настройке OpenVPN сервера на OpenWRT, а то у меня самого мозгов не хватает - сделал сертификаты, а конфиги править - проблема.
Буду очень признателен.
Товарищ живет в другом городе, его нужно выпустить посредством OpenVPN сервера, поднятого на моей стороне в эти самые тырнеты.
Администратор запретил публиковать записи гостям.