Добро пожаловать, Гость
Логин: Пароль: Запомнить меня
  • Страница:
  • 1
  • 2

ТЕМА: Разблокирование 12, 13 и 14-го каналов wifi в openwrt

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 13 нояб 2012 21:19 #1

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13

Сделал я мод внешней антенны на своем wr703n, подключил направленную антенну и начал настраивать получение интернета по wifi, но был ненадолго озадачен отсутствием искомой точки доступа в списке видимых. А все дело в том, что работала она на 13 канале wifi. Как оказалось openwrt имеет некоторое соглашение с производителем wifi чипов atheros, в соответствии с которым openwrt отключает поддержу 12,13,14 каналов wifi в своих прошивках. Сделано это по-видимому для максимального соблюдения законодательства, т.к. во многих европейских странах использование 12,13 и 14-го каналов wifi запрещено. Но для Украины и России 12 и 13 каналы разрешены, поэтому я хочу полностью воспользоваться своими правами:)

Подробнее...
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 23 янв 2013 13:04 #2

  • botan
  • botan аватар
насколько я знаю - 12-14 каналы не зря заблокированы для европы и америки - потому что эти каналы граничат с федеральными, и соответветсвенно могут (и будут!) вносить помехи в соседние каналы. вы вот готовы взять на себя отвественность за чьюто смерть, только потому что скорая помощь не смогла вовремя получить информацию о том что в ближайшей больнице в данный момент занята операционная на несколько часов и что нужно ехать в другую? я бы так не рискнул бы. но вам ведь плевать, верно? еще и других подстрекаете на это дело... жесть вобщем. пожарные и спецслужбы кстати тоже используют диапазон близкий к 13-14 каналам. такчто играете с огнем, одумайтесь пока не поздно.
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 23 янв 2013 14:57 #3

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
насколько я знаю - 12-14 каналы не зря заблокированы для европы и америки - потому что эти каналы граничат с федеральными, и соответветсвенно могут (и будут!) вносить помехи в соседние каналы. вы вот готовы взять на себя отвественность за чьюто смерть, только потому что скорая помощь не смогла вовремя получить информацию о том что в ближайшей больнице в данный момент занята операционная на несколько часов и что нужно ехать в другую? я бы так не рискнул бы. но вам ведь плевать, верно? еще и других подстрекаете на это дело... жесть вобщем. пожарные и спецслужбы кстати тоже используют диапазон близкий к 13-14 каналам. такчто играете с огнем, одумайтесь пока не поздно.

Лично я не использую 14 канал, а работаю на 13-м, как менее загруженном у меня. 13-й канал разрешен в Украине и России, так что простите. Я ничего не нарушаю.
Отдельно разблокировать 13-й без 14-го не получится
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 13:18 #4

  • ordman
  • ordman аватар
вай фай перестал работать выдает ошибку
root@OpenWrt:~# wifi up
Configuration file: /var/run/hostapd-phy0.conf
Could not set interface wlan0 flags: Cannot assign requested address
nl80211: Could not set interface 'wlan0' UP
nl80211 driver initialization failed.
rmdir[ctrl_interface]: No such file or directory
Failed to start hostapd for phy0
можете помочь пожалуста
при выполнении команды на вывод мак адреса видает все нули 00:00:00: и.т.д
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 14:36 #5

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
вай фай перестал работать выдает ошибку
root@OpenWrt:~# wifi up
Configuration file: /var/run/hostapd-phy0.conf
Could not set interface wlan0 flags: Cannot assign requested address
nl80211: Could not set interface 'wlan0' UP
nl80211 driver initialization failed.
rmdir[ctrl_interface]: No such file or directory
Failed to start hostapd for phy0
можете помочь пожалуста
при выполнении команды на вывод мак адреса видает все нули 00:00:00: и.т.д

Мало информации
1.Какой роутер
2.Какая прошивка
3.Вывод команд выложите
nano /etc/config/wireless
nano /etc/config/network
4.Проштудируйте мою статью

Навскидку возможно отключен wifi. Проверьте опцию
option disabled 0
в файле /etc/config/wireless
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 19:14 #6

  • ordman
  • ordman аватар
1)D-Link Dir 330
2)Linux OpenWrt 2.6.32.27 #3
3)root@OpenWrt:~# cat /etc/config/wireless
config wifi-device radio0
option type mac80211
option channel 11
option macaddr 00:00:00:00:00:00
option hwmode 11g
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1
config wifi-iface
option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption none
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 19:16 #7

  • ordman
  • ordman аватар
4)root@OpenWrt:~# cat /etc/config/network
config 'switch' 'eth0'
option 'enable' '1'
option 'vlan0' '5'
option 'vlan1' '5'
config 'switch_vlan' 'eth0_0'
option 'device' 'eth0'
option 'vlan' '0'
option 'ports' '0 1 2 3 4 5u'
config 'interface' 'loopback'
option 'ifname' 'lo'
option 'proto' 'static'
option 'ipaddr' '127.0.0.1'
option 'netmask' '255.0.0.0'
config 'interface' 'lan'
option 'type' 'bridge'
option 'ifname' 'eth0'
option 'macaddr' '00:90:4c:4e:00:0c'
option 'proto' 'static'
option 'netmask' '255.255.255.0'
option 'ipaddr' '192.168.0.2'
option 'gateway' '192.168.0.1'
option 'dns' '192.168.0.1'
option 'broadcast' '192.168.0.255'
config 'interface' 'wan'
option 'type' 'bridge'
option 'ifname' 'eth1'
option '_orig_ifname' 'eth1'
option '_orig_bridge' 'true'
option 'proto' 'dhcp'
option 'hostname' 'GVtrol'
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 19:36 #8

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
1)D-Link Dir 330
2)Linux OpenWrt 2.6.32.27 #3
3)root@OpenWrt:~# cat /etc/config/wireless
config wifi-device radio0
option type mac80211
option channel 11
option macaddr 00:00:00:00:00:00
option hwmode 11g
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 1
config wifi-iface
option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption none

Я ж вам в первом сообщении еще написал первым делом проверить
option disabled 1 - должно быть 0, что бы включился wifi.
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 20:31 #9

  • ordman
  • ordman аватар
  • Offline
  • Новый участник
  • Сообщений: 9
  • Репутация: 0
Да да уже исправил, + сделал как вы говорили немного в другой теме
mkdir /mnt/sda1
mount /dev/sda1 /mnt/sda1
mkdir /tmp/cproot
mount --bind / /tmp/cproot
tar -C /tmp/cproot -cvf - . | tar -C /mnt/sda1 -xvf -
sync ; umount /mnt/sda1
umount /tmp/cproot
но теперь вот такая проблема
root@OpenWrt:~# wifi up
Configuration file: /var/run/hostapd-phy0.conf
Line 52: invalid WPA passphrase length 7 (expected 8..63)
WPA-PSK enabled, but PSK or passphrase is not configured.
2 errors found in configuration file '/var/run/hostapd-phy0.conf'
Failed to start hostapd for phy0
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 20:36 #10

  • ordman
  • ordman аватар
  • Offline
  • Новый участник
  • Сообщений: 9
  • Репутация: 0
Ураааа заработало вроде
root@OpenWrt:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.

br-lan no wireless extensions.

br-wan no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on
а можете по подробнее объяснить вот эти команды :
mkdir /mnt/sda1
mount /dev/sda1 /mnt/sda1
mkdir /tmp/cproot
mount --bind / /tmp/cproot
tar -C /tmp/cproot -cvf - . | tar -C /mnt/sda1 -xvf -
sync ; umount /mnt/sda1
umount /tmp/cproot
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 20:51 #11

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
Ураааа заработало вроде
а можете по подробнее объяснить вот эти команды :
mkdir /mnt/sda1
mount /dev/sda1 /mnt/sda1
mkdir /tmp/cproot
mount --bind / /tmp/cproot
tar -C /tmp/cproot -cvf - . | tar -C /mnt/sda1 -xvf -
sync ; umount /mnt/sda1
umount /tmp/cproot
:-) Ну так если вы уже до этого этапа дошли, то установите вебинтерфейс как там в статье написано в конце и жизнь гораздо упростится))

mkdir /mnt/sda1 - создает точку монтирования диска
mount /dev/sda1 /mnt/sda1 - монтируем первый раздел флешки в точку монтирования
mkdir /tmp/cproot - создаем точку монтирования для корневой системы в памяти роутера
mount --bind / /tmp/cproot - монтируем ее же
tar -C /tmp/cproot -cvf - . | tar -C /mnt/sda1 -xvf - копируем все файлы корневой системы с роутера на флешку
sync ; umount /mnt/sda1 - отключем раздел
umount /tmp/cproot - отключаем раздел, что бы после перезагрузки вдруг не возникли ошибки
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 21:05 #12

  • ordman
  • ordman аватар
  • Offline
  • Новый участник
  • Сообщений: 9
  • Репутация: 0
mkdir /mnt/sda1 - создает точку монтирования диска
mount /dev/sda1 /mnt/sda1 - монтируем первый раздел флешки в точку монтирования
mkdir /tmp/cproot - создаем точку монтирования для корневой системы в памяти роутера
mount --bind / /tmp/cproot - монтируем ее же
tar -C /tmp/cproot -cvf - . | tar -C /mnt/sda1 -xvf - копируем все файлы корневой системы с роутера на флешку
sync ; umount /mnt/sda1 - отключем раздел
umount /tmp/cproot - отключаем раздел, что бы после перезагрузки вдруг не возникли ошибки[/quote]
как же все круто.
я делал по инструкции в которой не было копирования корневой ФС на флешку
из за этого не работало wifi так как не видело драйверов , вот теперь буду знать что надо после коректировки ФС таба еще и переносить все , огромное спасибо .
и про между прочем что луче :
1) webif
2) luci
как на ваше усмотрение, и почему ?
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 21:21 #13

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
mkdir /mnt/sda1 - создает точку монтирования диска
mount /dev/sda1 /mnt/sda1 - монтируем первый раздел флешки в точку монтирования
mkdir /tmp/cproot - создаем точку монтирования для корневой системы в памяти роутера
mount --bind / /tmp/cproot - монтируем ее же
tar -C /tmp/cproot -cvf - . | tar -C /mnt/sda1 -xvf - копируем все файлы корневой системы с роутера на флешку
sync ; umount /mnt/sda1 - отключем раздел
umount /tmp/cproot - отключаем раздел, что бы после перезагрузки вдруг не возникли ошибки
как же все круто.
я делал по инструкции в которой не было копирования корневой ФС на флешку
из за этого не работало wifi так как не видело драйверов , вот теперь буду знать что надо после коректировки ФС таба еще и переносить все , огромное спасибо .
и про между прочем что луче :
1) webif
2) luci
как на ваше усмотрение, и почему ?[/quote]

У меня стоял webif - вылазили ошибки ввиде неработающих страниц вебинтерфейса, приходилось разбираться и вытягивать скрипты с их сайта с исходниками. Как я понял они сейчас слабо развиваются, хорошо стартанули в свое время и сдулись.
В luci - все работает из коробки, явных косяков не находил, обновления вроде выходят стабильно, можно сказать, что официально поддерживается openwrt. WebIf - это как бы сторонний проект...
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 21:37 #14

  • ordman
  • ordman аватар
  • Offline
  • Новый участник
  • Сообщений: 9
  • Репутация: 0
У меня стоял webif - вылазили ошибки ввиде неработающих страниц вебинтерфейса, приходилось разбираться и вытягивать скрипты с их сайта с исходниками. Как я понял они сейчас слабо развиваются, хорошо стартанули в свое время и сдулись.
В luci - все работает из коробки, явных косяков не находил, обновления вроде выходят стабильно, можно сказать, что официально поддерживается openwrt. WebIf - это как бы сторонний проект...
коль пошла такая пьянка , не подскажете можно ли обновить ядро или переконфигурировать прям в роутере
и как это можно сделать?
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 21:48 #15

  • ordman
  • ordman аватар
  • Offline
  • Новый участник
  • Сообщений: 9
  • Репутация: 0
root@OpenWrt:~# wifi
Configuration file: /var/run/hostapd-phy0.conf
Could not set interface wlan0 flags: Cannot assign requested address
nl80211: Could not set interface 'wlan0' UP
nl80211 driver initialization failed.
rmdir[ctrl_interface]: No such file or directory
Failed to start hostapd for phy0
а что єто ?
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 21:48 #16

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
коль пошла такая пьянка , не подскажете можно ли обновить ядро или переконфигурировать прям в роутере
и как это можно сделать?
Нет нельзя
1. Ядро в памяти роутера примонтировано без возможности записи. Даже если попытаться там собрать ядро то по времени оно будет собираться пару лет наверно))
2. Можно только доустановить определенные модули ядра, типа kmod-video-core и т.п. Но они должны быть собраны из той же версии исходников что и прошивка.

Постарайтесь пожалуйста вопросы задавать в сооветсвующих статьях, а то тут мы уже сильно ушли от тематики разблокирования каналов wifi :-)
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 22:05 #17

  • ordman
  • ordman аватар
  • Offline
  • Новый участник
  • Сообщений: 9
  • Репутация: 0
без возможности записи. Даже если попытаться там собрать ядро то по времени оно будет собираться пару лет наверно))
2. Можно только доустановить определенные модули ядра, типа kmod-video-core и т.п. Но они должны быть собраны из той же версии исходников что и прошивка.

Постарайтесь пожалуйста вопросы задавать в сооветсвующих статьях, а то тут мы уже сильно ушли от тематики разблокирования каналов wifi :-)
root@OpenWrt:~# wifi
Configuration file: /var/run/hostapd-phy0.conf
Could not set interface wlan0 flags: Cannot assign requested address
nl80211: Could not set interface 'wlan0' UP
nl80211 driver initialization failed.
rmdir[ctrl_interface]: No such file or directory
Failed to start hostapd for phy0
а как с этим бороться ?
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 22:27 #18

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
То что я нагуглил - это походу специфическая ошибка вашего роутра. На него судя из вики я так понял еще и нет полноценной прошивки, так что все может быть.

Единственное, что могу предложить попробывать - это поменять в конфиге макадрес
option macaddr 00:00:00:00:00:00
на например
option macaddr 00:90:4C:C1:00:01

Вот еще тема, там такую же ошибку обговаривают.
forum.ixbt.com/topic.cgi?id=14:49819-54

Тут только вы сами себе сможете помочь...
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 22:31 #19

  • ordman
  • ordman аватар
  • Offline
  • Новый участник
  • Сообщений: 9
  • Репутация: 0
То что я нагуглил - это походу специфическая ошибка вашего роутра. На него судя из вики я так понял еще и нет полноценной прошивки, так что все может быть.

Единственное, что могу предложить попробывать - это поменять в конфиге макадрес
option macaddr 00:00:00:00:00:00
на например
option macaddr 00:90:4C:C1:00:01

Вот еще тема, там такую же ошибку обговаривают.
forum.ixbt.com/topic.cgi?id=14:49819-54

Тут только вы сами себе сможете помочь...
прикол в том что когда я поставил чистую прошивку то вайфай роботал, а когдаперенес все на флешку то перестало
Администратор запретил публиковать записи гостям.

Разблокирование 12, 13 и 14-го каналов wifi в openwrt 24 янв 2013 22:38 #20

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
То что я нагуглил - это походу специфическая ошибка вашего роутра. На него судя из вики я так понял еще и нет полноценной прошивки, так что все может быть.

Единственное, что могу предложить попробывать - это поменять в конфиге макадрес
option macaddr 00:00:00:00:00:00
на например
option macaddr 00:90:4C:C1:00:01

Вот еще тема, там такую же ошибку обговаривают.
forum.ixbt.com/topic.cgi?id=14:49819-54

Тут только вы сами себе сможете помочь...
прикол в том что когда я поставил чистую прошивку то вайфай роботал, а когдаперенес все на флешку то перестало

А ну так в таких случаех проще заново пройти процедуру переноса на флешку...
Или сперва поставьте Luci на флешку и попробуйте настроить с него, он может подправит ваши конгфиги.
Администратор запретил публиковать записи гостям.
  • Страница:
  • 1
  • 2