Добро пожаловать, Гость
Логин: Пароль: Запомнить меня

ТЕМА: Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A)

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 31 июль 2012 21:24 #1

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13

В данной статья я хочу поделиться своим опытом по установке прошивки Openwrt на флешку. В качестве подопытного роутера будет использоваться TP-Link TL-WR703N. В результате Openwrt будет грузится не с внутренней памяти роутера, а с флешки, что позволит ставить на нее неограниченное количество приложений. Также данный материал будет справедлив для роутера DIR-320 revA1(A2), что проверено мной лично и для массы других устройств, которые есть в списке поддержки openwrt.

Подробнее...
Администратор запретил публиковать записи гостям.
Спасибо сказали: Fortunate

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 06 нояб 2012 13:07 #2

  • fancky
  • fancky аватар
Хорошая статья, жаль что раньше не нашел.
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 07 нояб 2012 01:24 #3

  • Сергей
  • Сергей аватар
Спасибо за инструкцию , прошу дополнить её! С переносом системы на флешку проблем нет , но не могу подключить ещё дополнительно жесткий диск. После перезагрузки вместо флешку оказывается подключен винт. В какой точке его нужно монтировать?
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 07 нояб 2012 09:59 #4

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
Спасибо за инструкцию , прошу дополнить её! С переносом системы на флешку проблем нет , но не могу подключить ещё дополнительно жесткий диск. После перезагрузки вместо флешку оказывается подключен винт. В какой точке его нужно монтировать?
Запустите команду dmesg
Там должны появиться строки
sda: sda1 - это винчестер если на нем всего один раздел
и
sdb: sdb1 sdb2 sdb3 - это флешка.
Вам нужно отключить флешку и hdd, перезагрузиться. Отредактировать файл /etc/config/fstab и поменять в секциях названия /dev/sda на /dev/sdb. Для винчестера можно добавить отдельную секцию. Например:
config mount
option target /hdd
option device /dev/sda1
option fstype ext4
option options rw,sync
option enabled 1
option enabled_fsck 0

Либо можно подмонтировать HDD в секцию "option target /home" изменив "option device /dev/sda2" на "option device /dev/sda1"
выключаем роутер от питания, подключаем флешку и винт, включаем питание. После этого должна пойти загрузка с флешки, но надо опять отредактировать файл /etc/config/fstab как перед этим, что бы подгрузились остальные разделы. Пока пишу по памяти, проверить смогу только сегодня вечером и добавлю в инструкцию.

P.S.
Добавил и вынес в отдельную статью.
http://autohome.org.ua/index.php/20-mount-flash-and-hdd-openwrt
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 06 дек 2012 21:04 #5

  • netwalker
  • netwalker аватар
Здравствуйте.
Спасибо Вам за инструкцию. Очень все понятно и наглядно. По Вашей инструкции настроил WNDR-3800. Все завелось как надо.
Единственное, с чем бьюсь - с настройкой прокси сервера (polipo).
Задача - поднять прокси на интерфейсе, смотрящем в Интернет, с доступом из того самого Интернета.
Сам прокси вроде работает, но доступа из Интернет к нему нет (я же, с локального компа, прописав IP и порт прокси в браузере нормально могу спокойно ходить в Интернет).
Поэтому хотелось бы попросить Вас разжевать этот вопрос.
Заранее огромное спасибо.
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 06 дек 2012 21:25 #6

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
Здравствуйте.
Спасибо Вам за инструкцию. Очень все понятно и наглядно. По Вашей инструкции настроил WNDR-3800. Все завелось как надо.
Единственное, с чем бьюсь - с настройкой прокси сервера (polipo).
Задача - поднять прокси на интерфейсе, смотрящем в Интернет, с доступом из того самого Интернета.
Сам прокси вроде работает, но доступа из Интернет к нему нет (я же, с локального компа, прописав IP и порт прокси в браузере нормально могу спокойно ходить в Интернет).
Поэтому хотелось бы попросить Вас разжевать этот вопрос.
Заранее огромное спасибо.
Не совсем понял вопрос. Как я понимаю, вы хотите сидя, например на работе подключится к своему домашнему роутеру и использовать его прокси? Если так, то думаю вам нужно открыть порты на polipo, т.к. по умолчанию openwrt рубит доступ из вне в целях безопасности. Как открыть доступ из вне на openwrt читаем в моей статье.

сейчас бегло просмотрел мануалы по polipo, по умолчанию он использует порт 8183 (проверте параметр proxyport = 8183 в конфигурационном файле), вот его и нужно открыть. Согласно моего мануала вам нужно добавит строки в фаервол
WAN='название интерфейса, смотрите в инструкции'
iptables -A input_rule -i $WAN -p tcp --dport 8183 -j ACCEPT
Отпишитесь пожалуйста о результатах.
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 06 дек 2012 22:56 #7

  • netwalker
  • netwalker аватар
Спасибо за столь быстрый ответ.
У меня прокси будет сидеть на порту 40000.
Соответственно я открываю порт 40000.
Для меня немного непонятны несколько моментов:
1) Каким должен быть IP адрес в конфигурационном файле прокси сервера (192.168.1.1 или внешний IP адрес, который роутер получает при старте PPPoE сессии)
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 07 дек 2012 01:22 #8

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
В общем у меня получилось запустить))
На днях наверно сделаю статью.
По поводу вопроса Каким должен быть IP адрес, ничего не меняй, оставь по умолчанию 0.0.0.0, тогда polipo слушает все интерфейсы.
Краткая инструкция
1.Ставлю polipo c веб интерфейсом luci
opkg update
opkg install luci-app-polipo
2.Заходим в веб интерфейс роутера и на вкладке polipo добавляем Allowed clients - ip adress компьютера с которого будем конектится к прокси. Это должен быть белый ip. И получается что он должен быть постоянным, иначе прийдется его каждый паз вручную менять в конфигурации.
3.Меняем если нужно Listen port, у тебя это 40000.
4.Ну и естественно открываем порт в фаерволе, о чем я писал ниже
5.А и наверно не мешало бы задать пароль на прокси, но я у себя пока не делал. Там вроде интуитивно все понятно.

С этими минимальными настройками у меня все заработало. Остальное там уже по вкусу настраиваются всякие примочки.

p.s. нашел как сделать доступ с любого ip.
Allowed clients - 0.0.0.0/0
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 07 дек 2012 01:58 #9

  • netwalker
  • netwalker аватар
Что самое интересное - я делаю все именно так, как Вы описали, но черт возьми, не работает.
Сам polipo стартует, но при проверке всякими чекерами проксей (checkerproxy.net) сервис говорит, что прокси не работает :(
Отупел уже.
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 07 дек 2012 02:11 #10

  • netwalker
  • netwalker аватар
Кажется я понял причину. У меня почему то не хочет открываться порт на роутере. :sad:
Дурь какая то.
Подскажите куда ковырнуть...
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 07 дек 2012 03:26 #11

  • netwalker
  • netwalker аватар
Отписываюсь.
Все таки я его домучил. Оказывается дело было в том, что я для облегчения своей жизни сохранил конфиги от старых версий OpenWRT, наивно полагая, что их можно будет из версии в версию просто перекидывать, дабы не прописывать одно и то же руками. Оказалось, что при таком раскладе оказался практически поломан файрволл. Из-за этого у меня и были проблемы. Удалил файрволл, переустановил заново, прописал что нужно в /etc/config/firewall руками, и все заработало.
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 07 дек 2012 17:09 #12

  • netwalker
  • netwalker аватар
Здравствуйте еще раз.
Не могли бы Вы помочь с настройкой авторизации на polipo?
Спасибо :oops:
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 07 дек 2012 21:26 #13

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
Здравствуйте еще раз.
Не могли бы Вы помочь с настройкой авторизации на polipo?
Спасибо :oops:
Думал что эта функция есть в веб-интерфейсе, а там оказалось, что оно для подключения к другому запароленому прокси.
Вобщем нужно править конфиг файл и добавить секцию general строку authCredentials = user:password
Проблема в том, что конфигурационный файл лежит по пути /var/etc/polipo.conf и когда я в нем делаю изменения они постоянно затираются после перезапуска polipo, походу он тупо каждый раз генерируется из веб-интерфуйса.
Поэтому я скопировал /var/etc/polipo.conf в /etc/polipo/polipo.conf и сделал в нем нужные изменения.
Для того что бы polipo заработал с данным конфигом запускаем его так
/usr/sbin/polipo -c /etc/polipo/polipo.conf

Мой конфиг на всякий случай

### AUTOGENERATED CONFIGURATION
### DO NOT EDIT
### SEE /etc/config/polipo INSTEAD

### SECTION daemon
pidFile = "/var/run/polipo.pid"
daemonise = true
### SECTION general
proxyAddress = "0.0.0.0"
chunkHighMark = 1048576
dnsQueryIPv6 = happily
dnsUseGethostbyname = reluctantly
allowedClients = "127.0.0.1", "0.0.0.0/0"
authCredentials = polipo:pwd
### SECTION cache
### SECTION pmm
### VALUES THAT ARE DISABLED WHEN EMPTY
diskCacheRoot = ""
logFile = ""
localDocumentRoot = ""

p.s Нашел более красивое решение. Нужно добавить в файл /etc/config/polipo в секцию general строку
option authCredentials user:password
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 08 дек 2012 14:04 #14

  • netwalker
  • netwalker аватар
p.s Нашел более красивое решение. Нужно добавить в файл /etc/config/polipo в секцию general строку
option authCredentials user:password
То есть в этом случае не нужно будет содержимое /var/etc/polipo.conf копировать в /etc/polipo.conf, а просто прописать в в файл /etc/config/polipo в секцию general строку
option authCredentials user:password и запускать его можно уже обычным способом, т.е. /etc/init.d/polipo start?
Или я что то не понял?
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 08 дек 2012 14:25 #15

  • mszerg
  • mszerg аватар
  • Offline
  • Администратор
  • Сообщений: 505
  • Спасибо получено: 39
  • Репутация: 13
Да, именно так)))
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 08 дек 2012 15:08 #16

  • netwalker
  • netwalker аватар
Да, именно так)))
Спасибо огромное.
Все работает. :-)
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 04 янв 2013 12:07 #17

  • rafa
  • rafa аватар
:D Уважение автор!!!!!
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 15 янв 2013 20:53 #18

  • solmedas
  • solmedas аватар
Спасибо! отлично, все работает.
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 25 янв 2013 08:16 #19

  • vit.aliy
  • vit.aliy аватар
  • Offline
  • Новый участник
  • Сообщений: 15
  • Репутация: 0
Огромное спасибо !!! Все получилось! Работает замечательно!
Администратор запретил публиковать записи гостям.

Установка OpenWrt на внешний носитель на роутере wr703n (или DIR-320 A) 31 янв 2013 20:29 #20

  • алекс
  • алекс аватар
у меня после перезагрузки такая ерунда:
df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 1.9M 1.9M 0 100% /rom
tmpfs 14.4M 96.0K 14.3M 1% /tmp
tmpfs 512.0K 0 512.0K 0% /dev
/dev/mtdblock3 4.7M 3.8M 924.0K 81% /overlay
mini_fo:/overlay 1.9M 1.9M 0 100% /
/dev/sda1 936.2M 17.5M 868.7M 2% /mnt/sda1
/dev/sda2 796.6M 4.0M 750.1M 1% /home

микросд флешка установлена в 3g модеме
Администратор запретил публиковать записи гостям.